Weather Watcher Live Screen messed up

Discussion in 'Weather Watcher - Help' started by Boofo, Jan 2, 2011.

  1. Boofo

    Boofo Well-Known Member

    Joined:
    Oct 15, 2008
    Messages:
    189
    Likes Received:
    0
    Where is V7.0.44? I only have V7.0.41.
     
  2. siliconman01

    siliconman01 Well-Known Member

    Joined:
    Jan 28, 2008
    Messages:
    255
    Likes Received:
    0
    See this post. 44 is provided.

    viewtopic.php?f=65&t=3827
     
  3. Boofo

    Boofo Well-Known Member

    Joined:
    Oct 15, 2008
    Messages:
    189
    Likes Received:
    0
    Thank you, sir. I must have missed that.
     
  4. msinger

    msinger Administrator
    Staff Member

    Joined:
    Nov 6, 2002
    Messages:
    4,660
    Likes Received:
    0
    I doubt installing drivers would cause this problem. Microsoft could have broke it by pushing a new IE update though.

    Boofo, which version of IE do you have installed?
     
  5. Boofo

    Boofo Well-Known Member

    Joined:
    Oct 15, 2008
    Messages:
    189
    Likes Received:
    0
    IE8. IE9 doesn't support XP. Blows that theory all to heck, huh? ;-)
     
  6. msinger

    msinger Administrator
    Staff Member

    Joined:
    Nov 6, 2002
    Messages:
    4,660
    Likes Received:
    0
  7. siliconman01

    siliconman01 Well-Known Member

    Joined:
    Jan 28, 2008
    Messages:
    255
    Likes Received:
    0
    Yes, 7.0.46A resolved the issue on my Windows 7 x64 Professional system. Mind if I ask what the resolution was and why it probably just started showing up today?
     
  8. msinger

    msinger Administrator
    Staff Member

    Joined:
    Nov 6, 2002
    Messages:
    4,660
    Likes Received:
    0
    I haven’t been able to reproduce this issue on any of my computers, but here are a few possible explanations:

    1) Weather Watcher Live uses an embedded IE control to display the interface in the main window. The GUI uses some scripting that has been deprecated in IE8+. That scripting is responsible for positioning the GUI areas that are pushed up into the top, left corner of your screenshot. The IE control renders content using an older version of IE, so the deprecation shouldn’t be an issue. Perhaps Microsoft pushed out an update that changed that functionality.

    2) You’re running some type of security-related application that is interfering with the scripting on your local machine and/or an application you’re using modified the way scripting is rendered on your local machine.

    And to resolve the issue, I removed the deprecated scripting from the GUI.
     
  9. Boofo

    Boofo Well-Known Member

    Joined:
    Oct 15, 2008
    Messages:
    189
    Likes Received:
    0
    7.0.46A also resolved my issue on XP Pro. Well done, Mike! Thank you, sir. ;-)

    Was that something that you had added on 7.0.41? That was the first version that ever gave me a problem like this.
     
  10. msinger

    msinger Administrator
    Staff Member

    Joined:
    Nov 6, 2002
    Messages:
    4,660
    Likes Received:
    0
    Boofo, I didn't add anything in 7.0.41, nor did I change anything in the EXE in the build above. I just replaced the Splendid2 skin scripting that was refusing to run on your local machine.
     
  11. Boofo

    Boofo Well-Known Member

    Joined:
    Oct 15, 2008
    Messages:
    189
    Likes Received:
    0
    Ah, okay, I guess I misunderstood. Now it makes sense why you wanted to folder files. It's nice to have WWL back looking right again. I sure missed it. ;-)