Getfile.exe taking up CPU and slowing computer

Discussion in 'Weather Watcher - Help' started by MurderHeWrote, Jul 1, 2008.

  1. MurderHeWrote

    MurderHeWrote Member

    Joined:
    Jul 1, 2008
    Messages:
    10
    Likes Received:
    0
    Every now and then the getfile.exe which is a part of Weather Watcher Live suddenly starts sucking up RAM and CPU. My computer slows down quite noticeably to the point where everything freezes and I sometimes have to shut down the process in the Task Manager just to get things working again.

    This should not be a problem. I have Windows XP with a Petium 4 Processor and 512 Mb of RAM along with an 80 Gb hard drive.

    Why does this keep happening? Anyone else ever have this trouble?

    I use WinMem Optimizer to keep my RAM usage balanced out, so I don't have RAM problems much.
     
  2. johngalt

    johngalt Well-Known Member

    Joined:
    Aug 11, 2005
    Messages:
    217
    Likes Received:
    0
  3. MurderHeWrote

    MurderHeWrote Member

    Joined:
    Jul 1, 2008
    Messages:
    10
    Likes Received:
    0
    I don't like the idea of uninstalling my WinCleaner Memory Optimizer.

    It hasn't harmed my computer in any way and many a time it has helped me recover my computer from a frozen state that I otherwise wouldn't have been able to fix without it.

    I can find NO negative remarks about it online anywhere. On the contrary, I find nothing but positive comments about it.

    I really doubt that ALL memory optimizers are bad and worthless.
     
  4. johngalt

    johngalt Well-Known Member

    Joined:
    Aug 11, 2005
    Messages:
    217
    Likes Received:
    0
    The *concept* of a RAM optimizer is what is bad - not individual products. Actually, to put it more succinctly, they are ineffective.

    Windows XP Memory manager already knows how to send items to the pagefile as needed for RAM - it keeps what it needs to in your RAM and gets rid of it if you start a new app that needs more RAM than is currently available. By running a RAM optimizer, you're increasing the load on the system resources as it will continually try to remove applications from active memory and send them to the pagefile, using more of your HD than is necessary.

    Remember, HDs are about 1000 times *slower* than RAM. You really don't want stuff paged unless you absolutely have to - and as I mentioned before, Windows XP can take care of that.

    If your RAM program is set to always keep a certain amount of RAM free, and all of a sudden WWL runs its download.exe and GetFile.exe programs, there is a good possibility that your RAM optimizer will send them to the page file *while they are active in RAM* - slowing down the performance of WWL.

    After all, the whole point of running WWL is to get *live* data, or as close to live as you can get. If you slow down that process, you're slowing down the Live part of the program. And if the program does not receive a response in a timely manner, then it will most likely give you an error.

    In your example on how it helped you out - if your computer were truly frozen, you'd never be able to get to your RAM optimizer to run it - so, in effect, you had an app or two frozen, not the entire computer.

    Finally, I should have been more concise in my previous post - I did not say *uninstall* it - I said do not use it - turn it off for a period (say a week) and see how things go.

    Also realize this - XP really, really *really* needs 1 GB of RAM to run efficiently. I understand that not everyone can go out and afford new machines / afford upgrades, but for less than the average tank of gas you can easily make that machine a 1 GB machine or more (if your motherboard will allow it).
     
  5. whatever

    whatever Well-Known Member

    Joined:
    Jan 18, 2008
    Messages:
    76
    Likes Received:
    0
    I have an ancient, single-core AMD Athlon 3000+ (2.1 GHz), and while I don't think my problem is as pronounced as MurderHeWrote's, I have noticed the same issue. I ended up using Process Lasso to force dl.exe and getfile.exe to run at idle priority each time they run. I don't run any RAM optimizer [sic] utilities.
     
  6. jlvaz

    jlvaz New Member

    Joined:
    Aug 30, 2008
    Messages:
    4
    Likes Received:
    0
    I had the same problem and do not have a RAM optimizer on my computer. I have XP with 1G RAM, DSL. I have by-passed the last 2 to 3 upgrades because of this problem. I downloaded the new upgrade a couple of night ago and my CPU kept going up to 100%, so kept re-starting my computer until I figured out what was causing the problem. When WW decided to download the info, that is when the CPU went up to 100% and would never release my CPU and one time I waited for 15 minutes before I re-started my computer. I have used WW for over 6 years, so very disappointed I had to remove it. I do not have SP3 on my computer since it is an HP...ya, I know HP has a fix, but know there are still problems with it. Normally I always update my Windows.

    Jan
     
  7. whatever

    whatever Well-Known Member

    Joined:
    Jan 18, 2008
    Messages:
    76
    Likes Received:
    0
    I had WinXP SP3, it made no difference to the problem. I also stopped using WW.
     
  8. jhuk

    jhuk New Member

    Joined:
    Oct 13, 2010
    Messages:
    1
    Likes Received:
    0
    I have the same issue. I have no 3rd party RAM manager. I have a DELL 2GHZ P4 and 1 GB of RAM. I have has this problem on every computer with which this software is installed. I am also a registered life time member. I need to get this to work properly. The longer the computer runs, the slower it gets. Right now I need to schedule a reboot every 3 hours to clear the computer so it does not freeze up or get slow.

    Any help in regard to this issue is greatly appreciated !


    All my best,

    Joseph M. Huk, Jr.
    All Hits HUKFM, ALL HIT MUSIC RADIO

    WWW.HUKFM.COM
     
  9. msinger

    msinger Administrator
    Staff Member

    Joined:
    Nov 6, 2002
    Messages:
    4,660
    Likes Received:
    0
    jhuk, "getfile.exe" is not part of the current version of Weather Watcher Live.

    Which version of Weather Watcher Live are you using? Did you check out the Windows Task Manager to see if there are any "dl.exe" or "ww.exe" processes using a large, consistent amount of the CPU?
     
  10. rhoadesb

    rhoadesb Member

    Joined:
    Jan 8, 2009
    Messages:
    19
    Likes Received:
    0
    I too have this problem.

    My PC either slows WAAAAAAAAY down or freezes when I run WWL. I have no idea why. It gobbles up a lot more memory than it used to.

    I'm running WWL 7.0.30 or later.

    Help. ;(
     
  11. msinger

    msinger Administrator
    Staff Member

    Joined:
    Nov 6, 2002
    Messages:
    4,660
    Likes Received:
    0
    rhoadesb, which version of Weather Watcher Live are you using?
     
  12. rhoadesb

    rhoadesb Member

    Joined:
    Jan 8, 2009
    Messages:
    19
    Likes Received:
    0
    7.0.33 to be exact.

    I just tried running it. It continually uses more and more memory slowly. I shut WWL down at 50,000K.

    It is basically almost useless like this. If it does retrieve the weather, it takes 5 minutes or more to do so.

    In an effort to help you analize the problem, I installed an old version of Weather Watcher (version 5.6.48). It works fine.
     
  13. msinger

    msinger Administrator
    Staff Member

    Joined:
    Nov 6, 2002
    Messages:
    4,660
    Likes Received:
    0
    rhoadesb, try upgrading to version 7.0.34 at:
    http://www.SingersCreations.com/WeatherWatcherLive/Download.asp

    If you're still experiencing the same slowness in 7.0.34, then please answer a few questions:

    1) What is the name of the process that is using 50k of memory?

    2) Are there any ww.exe or dl.exe processes in the Windows Task Manager that are using a consistent amount of CPU for an extended period of time?

    3) When did this problem start?
     
  14. rhoadesb

    rhoadesb Member

    Joined:
    Jan 8, 2009
    Messages:
    19
    Likes Received:
    0
    I just updated to 7.0.34. The problem still exists.

    As I added to the last post... I have an old version of WW (5.6.48) and it works fine.

    The last time I looked, task manager showed ww.exe running but no dl.exe. ww.exe is the one using ... this time 70,000k ram. I noted at one point 99% cpu useage, but that seemed to be short lived, and it went back to a more normal level.

    3) When did this problem start?
    Recently. And possibly related: Recently I was forced to switch from my laptop to my backup PC. This one is running Windows XP 256mb ram. ... The problem started about the same time.

    edit:

    a few minutes later:

    I ran WWL again...this time I did see dl.exe in task manager. But it was only using maybe 5,000k. Also, for whatever reason it worked a little better this time, not much , but better.

    and a few minutes later:
    Ran again ... this time using massive memory and cpu amounts. ????
     
  15. msinger

    msinger Administrator
    Staff Member

    Joined:
    Nov 6, 2002
    Messages:
    4,660
    Likes Received:
    0
    rhoadesb, tell me some more about your computer:

    1) Which Windows service pack is installed?

    2) Do you have all of the Windows updates installed?

    3) Which version of Internet Explorer do you have?
     
  16. rhoadesb

    rhoadesb Member

    Joined:
    Jan 8, 2009
    Messages:
    19
    Likes Received:
    0
    1) Which Windows service pack is installed?
    SP2

    2) Do you have all of the Windows updates installed?
    No

    3) Which version of Internet Explorer do you have?
    6.0
     
  17. msinger

    msinger Administrator
    Staff Member

    Joined:
    Nov 6, 2002
    Messages:
    4,660
    Likes Received:
    0
    rhoadesb, that is most likely a big part of the issue (the other being the small amount of RAM). Weather Watcher Live runs on top of Microsoft technologies, so it's best to have the latest updates installed. Here's what I recommend:

    - Windows XP SP3
    - All available Windows updates
    - Internet Explorer 8
     
  18. rhoadesb

    rhoadesb Member

    Joined:
    Jan 8, 2009
    Messages:
    19
    Likes Received:
    0
    OK...thanks.
     
  19. whatever

    whatever Well-Known Member

    Joined:
    Jan 18, 2008
    Messages:
    76
    Likes Received:
    0
    I've had a similar problem. I was using WWL 7.0.34, along with:

    - Windows XP SP3
    - All available Windows updates
    - Internet Explorer 8
    - 2.5 GB RAM

    I had to stop using WWL because ww.exe would occasionally use ~70-80% of CPU, continually.
     
  20. rhoadesb

    rhoadesb Member

    Joined:
    Jan 8, 2009
    Messages:
    19
    Likes Received:
    0
    To assist with helping others, I am back to state results.

    I have dialup, so getting SP3 installed is a time consuming job.

    I do have WWL 7.0.34 up and running 95% properly, although SP3 is not yet completely installed. I think what made the biggest difference was replacing Internet Explorer version 6.0 with version 8.0.

    The rest of my difficulty appears to be mostly or totally only having 256mb ram installed.

    I hope that helps ... someone.