7.0.11 Skin Issues with WU stations

Discussion in 'Weather Watcher - Help' started by rickny, Jul 26, 2010.

  1. rickny

    rickny Active Member

    Joined:
    Feb 28, 2005
    Messages:
    31
    Likes Received:
    0
    Hi Mike.. In 7.0.11, it seems if you select a Weather Underground station, and then try to bring up the full program, all you get is a blank white square instead of the user interface. If you then try to switch back to a NWS or WeatherBug station, you will get endless script errors, and need to kill the ww.exe process. Switching back to a NWS or Weatherbug station, killing the ww.exe process, and then relaunching appears to bring up a correct UI.

    For the specific station -- search 11949, select Manorville, NY (Pine Barrens - Weather Underground)
     
  2. danwdoo

    danwdoo Member

    Joined:
    Oct 27, 2009
    Messages:
    16
    Likes Received:
    0
    I'm also having problems with WU stations but for me, all the forecast icons are just red x placeholders. Otherwise the rests if the interface seems to be working. If I change back to a weather bug station, everything works again.

    Danny
     
  3. msinger

    msinger Administrator
    Staff Member

    Joined:
    Nov 6, 2002
    Messages:
    4,660
    Likes Received:
    0
    rickny, which Interface Skin is selected in the "Skins" section of the Weather Watcher Live Options window? Only the "Splendid2" skin is compatible with version 7.

    danwdoo, which Forecast Icons are selected in the "Skins" section of the Weather Watcher Live Options window? Do you notice any difference if you select a different forecast icons?
     
  4. edwinvogel

    edwinvogel Active Member

    Joined:
    Nov 10, 2005
    Messages:
    34
    Likes Received:
    0
    Hi Mike, I too have the same problem as rickny had posted and I do have the splended 2 skin selected still only a blank screen.
    Ed
     
  5. danwdoo

    danwdoo Member

    Joined:
    Oct 27, 2009
    Messages:
    16
    Likes Received:
    0
    @Mike

    I've tried every icon and all of them exhibit the same behavior.

    Danny
     
  6. rickny

    rickny Active Member

    Joined:
    Feb 28, 2005
    Messages:
    31
    Likes Received:
    0
    OK.. Tried this out on two computers.. As it turns out, my home computer was set to 'Splendid' and not 'Splendid2' -- that fixed the white box issue. On my work computer, it was already using 'Splendid2'

    On my home computer, I noticed the forecast icons were red X's until I did an update.. In fact -- I realized that if you change the forecast icons in the options, they don't actually change until the program does an update. Is this expected behavior?

    Also -- on my home computer, some, but not all elements of the UI are missing with the same skins, icons, etc between two machines. After I changed to 'Splendid2', some - but not all - of those UI features repaired themselves. But it required me to run the 7.0.11 installer again for it to completely fix the UI.


    Also --on WUnderground stations, when looking at daily forecasts -- for evening conditions, it displays "Sunny" instead of "Clear".

    What are the limitations of using WUnderground PWS stations? Where does the forecast come from in that case? Does it just pull the regular WUnderground forecast for that area?
     
  7. whatever

    whatever Well-Known Member

    Joined:
    Jan 18, 2008
    Messages:
    76
    Likes Received:
    0
    Whenever I use a WU station, I have red Xs, and they stay permanently. Updating doesn't help, even restarting WWL makes no diff.

    The forecast text is also nonsense. The daily forecast text is saying 60% chance of rain/t-storms, but if I look at the hourly text, it has 52% throughout the day. But if I switch back to the NWS station, the daily text says 52% and so does the hourly--which makes sense.
     
  8. msinger

    msinger Administrator
    Staff Member

    Joined:
    Nov 6, 2002
    Messages:
    4,660
    Likes Received:
    0
    I just pushed out a new Weather Watcher Live update. Right-click the Weather Watcher Live system tray icon and choose "Check for New Version" to download the update.

    Please let me know if any of the above issues still exists after updating.
     
  9. danwdoo

    danwdoo Member

    Joined:
    Oct 27, 2009
    Messages:
    16
    Likes Received:
    0
    It seems mostly fixed, but I'm getting some weird question mark icons in the tray tool tip for the nightime hours. In the hourly screen it works fine. Is this the expected behavior?
     
  10. msinger

    msinger Administrator
    Staff Member

    Joined:
    Nov 6, 2002
    Messages:
    4,660
    Likes Received:
    0
    danwdoo, the icons should match in both places. I have a few questions for you:

    1) Which "Tray Icon" set is selected in "Skins" section of the Weather Watcher Live Options window?

    2) Which weather station are you using?
     
  11. danwdoo

    danwdoo Member

    Joined:
    Oct 27, 2009
    Messages:
    16
    Likes Received:
    0
    I've tried all the icon sets and all have some kind of problem with the night time icons. Some show a blank white box, some show N/A and the weather bug icons show the question marks. The station I am using is Nalchik Russia (airport from WU). The daily icons also have a red X in the upper left corner even though the icon is there. This is only at the bottom of the now screen and not on the daily tab. It did not seem to be there before so not sure what is up with that.
     
  12. edwinvogel

    edwinvogel Active Member

    Joined:
    Nov 10, 2005
    Messages:
    34
    Likes Received:
    0
    Mike, thanks it seems your new Weather Watcher Live update that you just pushed out did the trick. All problems including BLANK WHITE SCREEN has been corrected. You sure do take care of your products.
    Thanks again.
    Ed.
     
  13. msinger

    msinger Administrator
    Staff Member

    Joined:
    Nov 6, 2002
    Messages:
    4,660
    Likes Received:
    0
    danwdoo, here's what I see right now:

    [​IMG]
     
  14. whatever

    whatever Well-Known Member

    Joined:
    Jan 18, 2008
    Messages:
    76
    Likes Received:
    0
    When I use the nearest WU station, I get daily forecasts that are out of order. (Please see the screen shot.) Also, toward the bottom, some of the days listed have "N/A" shown in place of a weekday name.

    [​IMG]

    And the daily/hourly POP percentages still don't match when I use a WU station. For example, right now the hourly forecasts for Wed all show "68%" straight through the day, but there is no daily forecast that shows a corresponding 68%. (I would say that the daily forecast for Wed doesn't show 68%, but actually there is no daily forecast for Wed being shown at all.)
     
  15. msinger

    msinger Administrator
    Staff Member

    Joined:
    Nov 6, 2002
    Messages:
    4,660
    Likes Received:
    0
    whatever, I'm working on a fix for those issues.
     
  16. danwdoo

    danwdoo Member

    Joined:
    Oct 27, 2009
    Messages:
    16
    Likes Received:
    0
    Hi Mike,

    On the tooltip I am getting this:
    [​IMG]

    On the program itself I am getting this:
    [​IMG]
     
  17. msinger

    msinger Administrator
    Staff Member

    Joined:
    Nov 6, 2002
    Messages:
    4,660
    Likes Received:
    0
    danwdoo, your images are not displaying. Can you repost them?
     
  18. danwdoo

    danwdoo Member

    Joined:
    Oct 27, 2009
    Messages:
    16
    Likes Received:
    0
  19. Steve

    Steve Active Member

    Joined:
    Mar 3, 2008
    Messages:
    43
    Likes Received:
    0
    I'm also having problems with WU stations.

    I'm using the Splendid2 skin and the main window looks like that:

    [​IMG]

    The tray icon tool tip looks even weirder:

    [​IMG]

    I have tried different WU stations - US and international.

    Steve
     
  20. msinger

    msinger Administrator
    Staff Member

    Joined:
    Nov 6, 2002
    Messages:
    4,660
    Likes Received:
    0
    Steve, thank you for the screenshots. I'm working on a fix.